Results 1 to 8 of 8

Thread: invalid battery

  1. #1
    Join Date
    Sep 2005
    Posts
    13
    Feedback Score
    0

    invalid battery

    I have a I450 and since today everytime I plug in my charger it tells me that the battery is invalid, can someone help me on this one.

  2. #2
    Join Date
    May 2004
    Posts
    1,241
    Device(s)
    iPhone 4
    Carrier(s)
    AT&T
    Feedback Score
    0
    Is it an OEM motorola battery? Or a generic third party one? Cuz if it isnt a Moto battery, that could be your problem.

  3. #3
    Join Date
    Sep 2005
    Posts
    13
    Feedback Score
    0
    it is the one from motorola.

  4. #4
    Join Date
    Sep 2005
    Location
    Fulton
    Posts
    727
    Device(s)
    Palm Pre
    Carrier(s)
    Sprint
    Feedback Score
    0
    My diag. is: It is a bad battery, or there is slight water damage. Try another battery and see if it goes away.

  5. #5
    Join Date
    Sep 2005
    Posts
    13
    Feedback Score
    0
    so I tried using the battery of a v551 on the phone and I still get the same message. Now this is the weird part I used the v551 to charge the i450 battery and it worked the problem is that the v551 is not mine.

  6. #6
    Join Date
    Sep 2005
    Location
    Fulton
    Posts
    727
    Device(s)
    Palm Pre
    Carrier(s)
    Sprint
    Feedback Score
    0
    So....take the phone back to who you bought it from, and they should be able to swap it out, after all, it is under warranty. If they won't, you can send it to Moto yourself and get it taken care of.

  7. #7
    Join Date
    Oct 2004
    Posts
    502
    Device(s)
    iPhone 4
    Carrier(s)
    ATT
    Feedback Score
    0
    I had the invalid battery thing pop up on my new i870, called nextel and was told to return it in the mail. I bought it online from the sprint store, funny thing the guy says never heard of that, well I decided not to send it back, just received it and I didn't want to be without a phone. So I took the battery out and found out that one of the battery prongs was pushed down and kinda of stuck behind part of the board, unstuck it and no problems. Thought I would pass it along in case anyone else came across the same problem.

  8. #8
    Join Date
    Aug 2009
    Posts
    11
    Feedback Score
    0

    Reviving an old thread

    Quote Originally Posted by captnoir
    I had the invalid battery thing pop up on my new i870, called nextel and was told to return it in the mail. I bought it online from the sprint store, funny thing the guy says never heard of that, well I decided not to send it back, just received it and I didn't want to be without a phone. So I took the battery out and found out that one of the battery prongs was pushed down and kinda of stuck behind part of the board, unstuck it and no problems. Thought I would pass it along in case anyone else came across the same problem.
    Had the " invalid battery " message on my i560, found this thread, checked and saw that one off the four prongs that the battery lines up with was broken off. Don't know if I will be able to get this repaired. Will use my wifes old mike phone for now. Thanks for the help.

Bookmarks