So I'm back on an Android-powered smartwatch, for reasons I might write about in another post. But first I'd like to share a helpful tip for my fellow Android smartwatch sufferers, one that will hopefully help rid your watch face of this most annoying icon:

Name:  wos01-offline.jpg
Views: 13
Size:  9.8 KB

Thanks to a thread on r/WearOS, I've been able to confirm what the icon means—that the watch is offline (ie. connected to the phone but somehow not the Internet)—and, more importantly, I have a fix to make it go away:

Here's what solved it for me:

  1. Open settings on your phone
  2. Go to "Lock Screen & Security" (or whatever it's called on your variant of Android)
  3. Go to "Trust agents"
  4. Turn off "Smart Lock (Google)"

As with anything, your mileage may vary (edit: and may require a reboot of the phone and/or watch, and may take a little time to sort itself out), but I haven't had a problem since I did this a couple days ago.
Name:  wos02-settings.jpg
Views: 13
Size:  14.0 KB

Here's what the relevant setting looks like on my OnePlus phone. The exact path was as follows:

Settings > Security > lock screen & Trust agents

And I'm happy to report that the offending icon has pretty much disappeared from my Skagen Wear OS watch. I've seen it once or twice first thing in the morning after my phone has been in a deep sleep, but otherwise not at all.

Hopefully this works for you as well as I did for me... Feel free to confirm or deny below!

Source: reddit