Results 1 to 4 of 4

Thread: HTC M9 only gets edge connection

  1. #1
    Join Date
    Apr 2010
    Posts
    72
    Carrier(s)
    Page Plus
    Feedback Score
    0

    HTC M9 only gets edge connection

    I purchased a t-mobile M9 off ebay that was said to be unlocked. I am using it on Mint (t-mobile mvno) and only getting edge connection. APN set to Mint's instructions but after reboot apn tries to default to the tmobile apn that cannot be deleted.

    Any suggestions?

  2. #2
    Join Date
    Jul 2005
    Location
    United States
    Posts
    18,522
    Device(s)
    Samsung Galaxy S9+
    Carrier(s)
    Sprint
    Feedback Score
    0
    You need to confirm if the phone has the correct LTE network bands. If it does not, nothing you can do to change that. The bands At&t and the bands used on T-Mobile may not match and would explain what is happening to you.
    Don't make me turn this car around.....

  3. #3
    Join Date
    Apr 2010
    Posts
    72
    Carrier(s)
    Page Plus
    Feedback Score
    0
    The HTC M9 was a T-mobile phone and it did have the correct bands for Mint (T-mobile mvno). I switched to a Nexus 6 and getting better reception, same sim card and location.

  4. #4
    Join Date
    Jul 2005
    Location
    United States
    Posts
    18,522
    Device(s)
    Samsung Galaxy S9+
    Carrier(s)
    Sprint
    Feedback Score
    0
    Have technical support do a technical ticket if it can't be resolved over the phone. Best wishes.
    Last edited by veriztd; 08-26-2019 at 07:53 AM.

Similar Threads

  1. htc one v only getting edge coverage, why?
    By jturkish in forum Tracfone/Net10
    Replies: 6
    Last Post: 05-22-2013, 09:46 PM
  2. My HD2 Only getting EDGE!
    By maiki in forum HTC
    Replies: 6
    Last Post: 08-07-2010, 01:54 PM
  3. 3G only, no EDGE connection??
    By uesnyc in forum HTC
    Replies: 5
    Last Post: 02-27-2009, 04:15 PM
  4. new USA N95 on AT&T only getting EDGE, not 3G
    By ChromeBro in forum Symbian/S60
    Replies: 16
    Last Post: 10-10-2007, 11:41 PM
  5. Can only get 'partial' connectivity
    By gmenfonce in forum LG
    Replies: 1
    Last Post: 05-01-2004, 01:43 PM

Tags for this Thread

Bookmarks