Results 1 to 7 of 7

Thread: Galaxy S3 4.3 OTA Update Issues

  1. #1
    Join Date
    Nov 2003
    Location
    Milwaukee, WI
    Posts
    37
    Device(s)
    Samsung Galaxy S III
    Carrier(s)
    US Cellular
    Feedback Score
    0

    Galaxy S3 4.3 OTA Update Issues

    I've been reading a lot of complaints of issues people have been having with their S3 after getting the OTA 4.3 update. I've yet to get it, but am scared to install it.

    I'd like to hear from the S3 owners who have updated to 4.3 via OTA. Who has not had problems and who has had problems? For those that have had issues, please list them and what if anything you were able to do to correct them.

    Scott

  2. #2
    Join Date
    Jul 2008
    Posts
    97
    Feedback Score
    0
    My update download on Thanksgiving day. I kept postponing the actual install, but I either accidentally hit install, or it only asks you so many times and then installs it for you.

    I haven't dug around too much yet, but already found one issue. I had my phone set to both ring & vibrate. Today when I got a call, the flash from the camera flashes while ringing. I turned the vibrate off and didn't notice it on the next call. I forgot to check for it though, so I can't say for sure if that fixed it.

  3. #3
    Join Date
    Nov 2003
    Location
    Milwaukee, WI
    Posts
    37
    Device(s)
    Samsung Galaxy S III
    Carrier(s)
    US Cellular
    Feedback Score
    0
    I found this fix for that issue on the web:

    Apparently the Accessability feature for Flash on Incoming calls gets turned on even tho it is unchecked. solution was to check it , then uncheck it , and it seems to be fixed. ( Settings / My Device / Accessibilty /Flash Notification)

    Also do another restart of your phone after the restart the update does.

  4. #4
    Join Date
    Feb 2011
    Location
    Central
    Posts
    103
    Feedback Score
    0
    The SAMSUNG S3-USC saga continues........nice.

  5. #5
    Join Date
    Oct 2006
    Location
    Milwaukee
    Posts
    9,694
    Device(s)
    Samsung Galaxy S3, iPhone 5
    Carrier(s)
    U.S. Cellular & VZW
    Feedback Score
    2 (100%)
    Yeah the update is pretty ******. It uninstalled SwiftKey, completely reset my ringtone settings, and has generally slowed down the system. It also made the dots on my unlock screen much smaller and less responsive.

    I'm not happy about this one.

    Sent with the HoFo App

  6. #6
    Join Date
    Apr 2009
    Posts
    687
    Carrier(s)
    U.S. Cellular
    Feedback Score
    0
    I haven't had a single problem since I installed. It actually spend up the phone and I used to roam all the time and now I don't and I get better signal and everything. Basically this update fixed everything I didn't like about the s3 and made me actually like the phone now. The update didn't mess with any of my settings or uninstall anything. I love the update

  7. #7
    Join Date
    May 2010
    Location
    Pacific Northwest
    Posts
    531
    Device(s)
    Galaxy Note II
    Carrier(s)
    US Cellular
    Feedback Score
    0
    I installed the update when I got the notification, and have had no problems with it. But, I only use my S3 as a media player...my main phone (Note 2) got the 4.3 update last week, and so far no problems. Before the update to my Note 2, 4G signal was weak, but after the 4.3 update and an update to PRL fixed the signal issue, now max bars and good signal strength. Only think I'm not liking is the added bloat from Samsung, lots of it.

Similar Threads

  1. Bell Galaxy S4 Bell MF3 OTA update?
    By chriskwarren in forum Bell/Virgin/Lucky/Solo
    Replies: 0
    Last Post: 07-09-2013, 06:30 PM
  2. Samsung Galaxy S III OTA Update 2/13/13
    By 503ducati in forum Android
    Replies: 0
    Last Post: 02-14-2013, 12:12 PM
  3. Todays tmobile galaxy s3 OTA update
    By Ramos1224 in forum Samsung
    Replies: 0
    Last Post: 08-26-2012, 09:02 PM
  4. Galaxy S III Firmware OTA Update
    By zoomdrb in forum USCellular
    Replies: 13
    Last Post: 08-21-2012, 08:36 AM
  5. OTA PRL Update issue?
    By jamboree in forum Sprint
    Replies: 33
    Last Post: 11-16-2004, 08:38 AM

Tags for this Thread

Bookmarks