Results 1 to 10 of 10

Thread: iMessage (iPhone) on Petro-Canada plan

  1. #1
    Join Date
    Aug 2012
    Posts
    1
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars

    iMessage (iPhone) on Petro-Canada plan

    Hi,

    Does anyone have iMessage registered on P-Can? I hear there is something about needing short-code SMS to be working for the iPhone to register its number to Apple's servers when enabling iMessage. Anyway around this?

    Thanks!

  2. #2
    Join Date
    May 2005
    Posts
    31
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    As many of you know, SpeakOut and Petro-Canada Mobility do not support the short code for Apple's FaceTime and iMessage registration. Turning these features on and off will never give you a successful registration of your phone number. This is okay if everyone you deal with only uses your e-mail addresses, but if you want your phone number to work as well, try these steps.

    Pre-requisite: First you need to have a jailbroken iPhone because you need to modify some files on your iPhone.
    Modify /System/Library/Carrier Bundles/iPhone/Rogers_ca.bundle/carrier.plist
    Modify PhoneNumberRegistrationGatewayAddress 28818773 or 49988 to +011447786205094
    Set: Settings->Messages->iMessage->OFF
    Set: Settings->FaceTime->FaceTime->OFF
    Reboot
    Set: Settings->Messages->iMessage->ON
    Set: Settings->FaceTime->FaceTime->ON


    Shortly, you will see that your phone number is registered to FaceTime and iMessage.

    This works for me and I didn't seem to be charged for those two international text messages.

    Please note that even though you have the phone number registered, iMessage still does not work using UMB because of the ports it uses. This is only helpful when you are on wifi.

  3. #3
    Join Date
    Apr 2007
    Posts
    2,803
    Feedback Score
    2 (100%)
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by ktse99 View Post
    As many of you know, SpeakOut and Petro-Canada Mobility do not support the short code for Apple's FaceTime and iMessage registration. Turning these features on and off will never give you a successful registration of your phone number. This is okay if everyone you deal with only uses your e-mail addresses, but if you want your phone number to work as well, try these steps.

    Pre-requisite: First you need to have a jailbroken iPhone because you need to modify some files on your iPhone.
    Modify /System/Library/Carrier Bundles/iPhone/Rogers_ca.bundle/carrier.plist
    Modify PhoneNumberRegistrationGatewayAddress 28818773 or 49988 to +011447786205094
    Set: Settings->Messages->iMessage->OFF
    Set: Settings->FaceTime->FaceTime->OFF
    Reboot
    Set: Settings->Messages->iMessage->ON
    Set: Settings->FaceTime->FaceTime->ON


    Shortly, you will see that your phone number is registered to FaceTime and iMessage.

    This works for me and I didn't seem to be charged for those two international text messages.

    Please note that even though you have the phone number registered, iMessage still does not work using UMB because of the ports it uses. This is only helpful when you are on wifi.
    Thanks ! All work on my sister phone...

    Sent from my XT615 using HowardForums

  4. #4
    Join Date
    Mar 2003
    Location
    Toronto
    Posts
    505
    Carrier(s)
    Rogers Wireless
    Feedback Score
    1 (100%)
    vBActivity - Stats
    vBActivity - Bars
    Does this still work? I tried it on my wife's iPhone last night but it still hasn't activated/registered. In the message settings, it says "verifying" for her number and is grayed out. For Facetime, it doesn't show her number either. How long does it usually take to register?

  5. #5
    Join Date
    Oct 2005
    Posts
    34
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by ktse99 View Post
    As many of you know, SpeakOut and Petro-Canada Mobility do not support the short code for Apple's FaceTime and iMessage registration. Turning these features on and off will never give you a successful registration of your phone number. This is okay if everyone you deal with only uses your e-mail addresses, but if you want your phone number to work as well, try these steps.

    Pre-requisite: First you need to have a jailbroken iPhone because you need to modify some files on your iPhone.
    Modify /System/Library/Carrier Bundles/iPhone/Rogers_ca.bundle/carrier.plist
    Modify PhoneNumberRegistrationGatewayAddress 28818773 or 49988 to +011447786205094
    Set: Settings->Messages->iMessage->OFF
    Set: Settings->FaceTime->FaceTime->OFF
    Reboot
    Set: Settings->Messages->iMessage->ON
    Set: Settings->FaceTime->FaceTime->ON


    Shortly, you will see that your phone number is registered to FaceTime and iMessage.

    This works for me and I didn't seem to be charged for those two international text messages.

    Please note that even though you have the phone number registered, iMessage still does not work using UMB because of the ports it uses. This is only helpful when you are on wifi.
    I'm a little confused here. I just bought an iPhone 4, and put in my PetroCanada SIM card which I'd cut down to size. I have the Anytime plan, and I don't have the mobile web browsing addon. I just want to be able to send iMessages back and forth when in a WiFi network, using my email address (not phone number) as a contact; I could care less about sending/receiving an iMessage over the data network.

    My iMessage setting still says "Waiting for activation....". Is there any way to accomplish this, short of jailbreaking the phone (which I'd really like to avoid doing)?

  6. #6
    Join Date
    Apr 2007
    Posts
    2,803
    Feedback Score
    2 (100%)
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by canadave View Post
    I'm a little confused here. I just bought an iPhone 4, and put in my PetroCanada SIM card which I'd cut down to size. I have the Anytime plan, and I don't have the mobile web browsing addon. I just want to be able to send iMessages back and forth when in a WiFi network, using my email address (not phone number) as a contact; I could care less about sending/receiving an iMessage over the data network.

    My iMessage setting still says "Waiting for activation....". Is there any way to accomplish this, short of jailbreaking the phone (which I'd really like to avoid doing)?
    You jailbreak... you don't have any others solutions if you want make this things !

  7. #7
    Join Date
    Oct 2005
    Posts
    34
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by o2qc418 View Post
    You jailbreak... you don't have any others solutions if you want make this things !
    No offence intended here, but I find that hard to believe/understand. For instance, my FaceTime is working perfectly fine. I don't quite understand why iMessage would/could not work similarly.

    I could understand the difficulty if it were using the cellular connection, too. But I'm talking about using it over my home's WiFi LAN, with my Apple ID, not my phone number.

  8. #8
    Join Date
    Apr 2007
    Posts
    2,803
    Feedback Score
    2 (100%)
    vBActivity - Stats
    vBActivity - Bars
    No offence here ... my english is just bad sorry !
    The problem is speakout don't support short code...
    Imessage and Facetime send sms via short code to activate the function !

  9. #9
    Join Date
    Oct 2005
    Posts
    34
    Feedback Score
    0
    vBActivity - Stats
    vBActivity - Bars
    Quote Originally Posted by o2qc418 View Post
    No offence here ... my english is just bad sorry !
    The problem is speakout don't support short code...
    Imessage and Facetime send sms via short code to activate the function !
    No worries about the English But as I said, then...how come Facetime works? Incidentally, if I go into the Facetime settings, it says "Activation unsucessful. Turn on Facetime to try again." Yet it works fine--and I've turned the iPhone off and on several times.

    Also...if iMessage and Facetime "send SMS via short code to activate the function"...then does that mean I can temporarily enable SMS on my iPhone, let the phone activate iMessage via SMS (10 cents per text message!), and then disable SMS and enjoy iMessage over WiFi into the future?

  10. #10
    Join Date
    Apr 2007
    Posts
    2,803
    Feedback Score
    2 (100%)
    vBActivity - Stats
    vBActivity - Bars
    i think yes ... imessage will work over wifi in the future

Similar Threads

  1. iPhone 4S works great on Petro Canada mobile browsing!
    By winnt7 in forum Petro Canada Mobile
    Replies: 27
    Last Post: 07-01-2012, 01:16 PM
  2. Replies: 15
    Last Post: 06-21-2012, 06:41 PM
  3. iPhone and iPad mobile browsing on Petro canada
    By shifty_ford in forum Petro Canada Mobile
    Replies: 0
    Last Post: 11-08-2011, 01:51 PM
  4. Internet setting for LG Xenon with Petro Canada plan
    By rayadams101 in forum General Canadian Prepaid/MVNO discussion
    Replies: 0
    Last Post: 06-10-2011, 03:36 PM

Tags for this Thread

Bookmarks