Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Jun 2009
    Location
    Brooklyn
    Posts
    10
    Phone
    Blackberry Curve 8900
    Carrier
    AT&T
    Feedback Score
    0

    iMessage problem please help!

    Hopefully someone is able to help me out. This problem is driving me crazy!

    Okay so ever since I upgraded to the iPhone 4S, people are unable to text my number. It goes through on their side, but I never receive it. (Talking about others with iPhones as well) So basically what I'm trying to say is iMessage doesn't work when they try to text to my phone #, however they are able to iMessage my email address which should go to my iPad, but it goes to my iPhone!

    Non-iPhone users are able to text my # with no problems. I'm going crazy here!

    I tried resetting my settings and everything, but it does not work!

    Please help!

  2. #2
    Join Date
    Jun 2002
    Location
    S.W. Florida, Englewood
    Posts
    1,633
    Carrier
    Verizon
    Feedback Score
    0
    sounds like if they have your cell number they need to change it in their contact list to the iphone slot.

  3. #3
    Join Date
    Aug 2004
    Location
    Brooklyn, NY
    Posts
    1,040
    Phone
    Iphone 3g 16 GB
    Carrier
    AT&T
    Feedback Score
    0
    you live in brooklyn? message me your number and I'll try sending you an imessage text. honestly I didn't even change the contact info to "iphone" slot and my new phones work just fine.

  4. #4
    Join Date
    Aug 2010
    Posts
    976
    Carrier
    Rogers
    Feedback Score
    0
    Quote Originally Posted by joe_fresh View Post
    sounds like if they have your cell number they need to change it in their contact list to the iphone slot.
    Yeah, this sounds exactly like it could be the issue. When people send you a message on iMessage, they don't just pick your name and send, they have to pick either the number or email associated with your name. It's exactly like Facetime in that when someone facetimes your number, it only goes to your phone, but if they message whatever email you associated with Facetime the cal goes to your iPad, iPod and Mac but NOT your iPhone by defaut. If however you go into settings and then manually add your email to both the facetime and imessage settings, THEN you can recieve those same messages and calls on your phone if someone uses your email.

  5. #5
    Join Date
    Oct 2005
    Posts
    716
    Phone
    64 GB iPhone 4s
    Carrier
    At&t
    Feedback Score
    0
    Do you have iMessage with your iCloud email address set up on your phone?
    What carrier are you with?
    Last edited by Cingulair; 10-26-2011 at 04:42 PM. Reason: Wanted to add more

  6. #6
    Join Date
    Mar 2004
    Location
    City by the Bay
    Posts
    266
    Carrier
    att
    Feedback Score
    0
    i had the same problem, until my friend told me to go : Settings> Messages> Receive at # - use your apple id or your cell #.

  7. #7
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    54
    Phone
    IPhone 3g
    Carrier
    Telus
    Feedback Score
    0
    But I can't seem to add my phone number

  8. #8
    Join Date
    Oct 2005
    Posts
    716
    Phone
    64 GB iPhone 4s
    Carrier
    At&t
    Feedback Score
    0
    Quote Originally Posted by landsyp View Post
    But I can't seem to add my phone number
    First of all, you need to be setup for iCloud.

    Second, go under Settings > Messages > Receive at and add your iCloud email address and your cell #. You will need both of these for imessaging to work properly.


    Make sure you use the iCloud address on both your cell and your iPad. This will insure that you get the same message to both devices.

  9. #9
    Join Date
    Nov 2006
    Location
    Canada
    Posts
    54
    Phone
    IPhone 3g
    Carrier
    Telus
    Feedback Score
    0
    I did that also and still not working...

  10. #10
    Join Date
    Nov 2006
    Location
    NYC
    Posts
    1,977
    Phone
    Galaxy Note 4
    Carrier
    T-Mobile
    Feedback Score
    0
    Quote Originally Posted by landsyp View Post
    But I can't seem to add my phone number
    Try turning iMessage off and on then reboot the phone if needed and it should allow you to add the number. I had to do that so it would verify my number so now everything works smoothly with iMessage, iPhone users can send me texts and it picks it up as an iMessage
    Mopar ftw!!! NYLX

  11. #11
    Join Date
    Jun 2002
    Location
    S.W. Florida, Englewood
    Posts
    1,633
    Carrier
    Verizon
    Feedback Score
    0
    i dont think you need to be registered to icloud because i have my icloud turned off. now in settings > messages i have imessage turned on and receive at my cell# and email.

  12. #12
    Join Date
    Oct 2005
    Posts
    716
    Phone
    64 GB iPhone 4s
    Carrier
    At&t
    Feedback Score
    0
    Quote Originally Posted by joe_fresh View Post
    i dont think you need to be registered to icloud because i have my icloud turned off. now in settings > messages i have imessage turned on and receive at my cell# and email.
    I could be wrong but, I think it's just a matter of you registering with iCloud with all of your devices.
    Do you have more than one Apple device? And if so do you get all your iMessages on more than one device?

  13. #13
    Join Date
    Jun 2002
    Location
    S.W. Florida, Englewood
    Posts
    1,633
    Carrier
    Verizon
    Feedback Score
    0
    I do have more than one apple device, my ipod touch does not receive my imessages, and also is not registered to icloud

  14. #14
    Join Date
    Oct 2003
    Location
    i live close to you
    Posts
    8,550
    Phone
    Note 5 , Note 8
    Carrier
    Verizon
    Feedback Score
    2 (100%)
    heres a weird problem iam having with imessage it was working perfect and now under imessage it says waiting for activation, why is it saying that now!!






    http://feedback.ebay.com/ws/eBayISAP...ab=AllFeedback

    ebay feedback above

    WELCOME TO THE UNITED STATES OF ILLEGAL IMMIGRATION

  15. #15
    Join Date
    Oct 2005
    Posts
    716
    Phone
    64 GB iPhone 4s
    Carrier
    At&t
    Feedback Score
    0
    Well folks, Blackberry Messenger used a pin code system Like it or not iMessenger uses a verification system. Therefore, you must use an Apple related email address, for best results. Choices are an iTunes email address or an iCloud email address. This is how it can tell you whether or not this person is registered with iCloud. How else can it tell? This allows them to make their messaging system secure as claimed.

    You must use at least one common (the same) email address on all your Apple devices to get it to transfer to all devices simultaneously and consistently. If you use this address when imessaging with friends, your whole convo will transfer automatically. Using a cell number won't get the same results. This address must be used as your Apple ID on the iPad and iPod (Settings > Messages > Receive at > Apple ID) and, it must be your Caller ID on your iPhone
    (in your iMessage sertings under Settings > Messages > Receive at > Caller ID) to make it work consistently on all devices.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. iMessage
    By flygirlk in forum Apple
    Replies: 43
    Last Post: 12-13-2011, 03:55 PM
  2. Replies: 17
    Last Post: 10-25-2011, 08:23 AM
  3. No group messaging with iMessage?
    By hightime in forum Apple
    Replies: 3
    Last Post: 10-18-2011, 12:34 PM
  4. iMessage Problem?
    By vneckjersey in forum Apple
    Replies: 4
    Last Post: 10-15-2011, 07:53 PM
  5. iOS 5 iMessage missed messages
    By staeit in forum Apple
    Replies: 0
    Last Post: 10-14-2011, 06:30 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •