Results 1 to 5 of 5

Thread: Screen problems with Treo 750 ATT model

  1. #1
    Join Date
    Dec 2006
    Posts
    15
    Feedback Score
    0

    Screen problems with Treo 750 ATT model

    Okay...I switched my SIM card to my son's RAZR...so he could see pictures and stuff. When I switched the SIMback to the Treo...problems. The screen goes blank, but I can hear it working. I have to Soft Reset it a bunch of times to get it to work, but once it timeouts, the screen doen't turn back on. I did a hard reset and it still does the same thing. It's not like I can reset it once and it works. I have to do it over and over and over, only for it to work for 30 minutes or so. Does anyone have an explanation? I called Palm and they said $200 to fix through them. I went to ATT and they said i could get upgarde to a new phone (lady said...wow that's an old one). I paid $500 and change to get it 2 years ago...jeesh. Anyway...help would be muchly appreciated

  2. #2
    Join Date
    Jul 2002
    Location
    Metro DC Area
    Posts
    461
    Carrier(s)
    Sprint
    Feedback Score
    0
    I don't have an explanation, but I do have a few Q's - in the interest of clarity:

    1) Did you mean SIM or memory card? I don't know why switching SIM's would enable seeing pics - I didn't think pics could be stored on SIMs. Perhaps he doesn't have a data acct to access online pics? (sorry if this question reveals my ignorance).
    2) Are you able to fiddle with screen settings?

    You obviously have to take the battery out to remove the sim, but have you tried keeping it out for a few hours? THat has helped me in the past.

    Also, what happens when you receive a message/call while it's blacked out? Does the screen come back on, or is it still non-functioning.

    Good luck bro

    cheers//dom
    "You keep using that word. I do not think it means what you think it means."

    Please click on a sponsor to keep the forums alive...

  3. #3
    Join Date
    Jan 2004
    Location
    Carolina, Puerto Rico
    Posts
    8,198
    Device(s)
    Samsung Galaxy S Glide
    Carrier(s)
    AT&T Go Phone
    Feedback Score
    0
    Quote Originally Posted by dominick
    1) Did you mean SIM or memory card? I don't know why switching SIM's would enable seeing pics - I didn't think pics could be stored on SIMs. Perhaps he doesn't have a data acct to access online pics? (sorry if this question reveals my ignorance).
    Most dumbphones, the RAZR included won't let you access any menus or files stored on the phone unless you have a valid SIM card inserted. It seems the OP's son lost his SIM card or switched to T-Mobile and he had to borrow someone else's AT&T SIM card (the OP in this case) to access pics stored on an old RAZR.

    That, or your data plan explanation if it was an online album.

  4. #4
    Join Date
    Sep 2004
    Posts
    1,155
    Feedback Score
    0
    I would try going into an AT&T store again and tell them you want a new SIM card (it is free). It's unlikely, but maybe something happened to it during the whole process.

  5. #5
    Join Date
    Dec 2006
    Posts
    15
    Feedback Score
    0
    Thanks for help.... I bought a Bold on Friday...tried putting the new SIM card in to no avail. I messed with the battery....did a hard reset...and lost the camera icon Did another hard reset and the camera icon returned...only until the screen cut off again. So far the BB Bold is more my speed function wise. It drops calls sometimes...but i don't have to shut everything down all the timje like the treo. I'll post any new details and please keep giving helpful hints. I especially like the term dumbphones too

Bookmarks