Page 5 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast
Results 61 to 75 of 95

Thread: modifying the shortcuts on W760i(a)

  1. #61
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    A step-by-step process of what you did would be nice, boooey. Do you think you could walk us through how you got the menu.ml file off the phone, what you changed in it and how to properly put it back on the w760?

  2. #62
    Join Date
    Jan 2003
    Posts
    205
    Device(s)
    SE C905a
    Feedback Score
    0
    Quote Originally Posted by NUTSgoWEEE
    A step-by-step process of what you did would be nice, boooey. Do you think you could walk us through how you got the menu.ml file off the phone, what you changed in it and how to properly put it back on the w760?
    These were the exact instructions I followed.

    http://www.esato.com/board/viewtopic.php?topic=153990

    FYI: to get the menu.ml off of the phone, just right click on it, and select READ.
    Then it will be placed in the sub folder ph_out of your A2Uploader directory.
    After that, just drag the modified file to the correct location, which is all listed in the instructions in that link.
    Last edited by boooey; 02-16-2009 at 02:35 PM.

  3. #63
    Join Date
    May 2006
    Posts
    53
    Device(s)
    Apple iPhone 3G white (16GB). Why did I wait so long to switch?
    Carrier(s)
    AT&T
    Feedback Score
    0
    Hi All... This might be a bit late, but I think why it worked for me is that I modified my Default.xml to contain every mod I applied via a Default_upgrade.xml file and also did the same to my Customize.xml file for every mod that I applied via Customize_upgrade.xml

    That way, whenever I do a Master Reset, I do not lose all my mods.

    As for finding other <ACTION type="Internal" str="*****" /> commands, I have done a search or two and only found a very small list over on ne-nse.com forums...

    From what I read over there, it does not look like "Inbox" is an acceptable Internal Hook... Which is odd, because you can set one of the Nav keys to Inbox via the Shortcuts menu in phone settings... Doesn't make sense to me.

  4. #64
    Join Date
    Jan 2003
    Posts
    205
    Device(s)
    SE C905a
    Feedback Score
    0
    Quote Originally Posted by NUTSgoWEEE
    Quick update - Here's what I've come up with so far.

    I set the Left Soft Key to camera (thanks to mbkatt's code!) and my nav-up key is still unlocked.

    I can't promise this will work on anyone else's phone because I'm unsure of the in-depth details but here's the procedure i've followed so far:

    -Started out with unlocked nav-up key and both left/right soft keys set to Sony's firmware default (media/phonebook)
    -Opened A2uploader and copied mbkatt's code (LEFT_SOFTKEY_HOOK.itm & LEFT_SOFTKEY_HOOK.xml) into their proper directories as instructed in mbkatt's post.
    -Navigated to /tpa/preset/custom and deleted custom_upgrade.xml then in /tpa/preset/default I deleted default_upgrade.xml as well
    -Shut down a2uploader, unplugged and turned on my phone and viola! left-softkey is camera and up-key is still messages!

    Hope you all get this working...
    very strange.. before I couldn't get both the nav up and the camera soft button to work at the same time.. I'm not sure exactly what happened, but for some reason, i just noticed that the right soft button now says camera! LOL... i have no idea why like 2 weeks later it all of a sudden is working and didn't before.. I think it may have happened after i set a photo from my picture album as my wallpaper.. i'm not really sure

    I have also done a lot of menu item mods, so maybe that did something too.
    very strange.

  5. #65
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    Mine was acting strange also. I just made a default_upgrade.xml file to change my phone name and when I started up my phone it worked, but my left and right shortcuts were back to media and contacts. But my nav-up key still works.

    When I was originally trying to find the shortcut string that would open my email, I gave up and left the button non-functioning so when I pressed it, nothing happened. When I woke up the next morning, I pressed it and it worked. Without restarting or anything... very strange.

  6. #66
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    Well now I can't get the left and right shortcuts back to how I had them... just my luck. Oh well, I give up for tonight, maybe it'll "magically" work after a few days...

  7. #67
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    Got it!
    Re-loaded all my .xml and .itm files and it worked so I moved onto the menu.ml modding. I noticed there were a lot of "internal" commands so I browsed around for a while. Here's what I came up with: (keep in mind "email" is for the debranded w760i with activesync set up. "messaging" is texting, mms, etc)

    Email Inbox:
    Msg_Email_Inbox

    Write New Email:
    Msg_Email_WriteNew

    Email Menu:
    Messaging_Email

    Messaging Inbox:
    Msg_Inbox

    Write New Message:
    Msg_WriteNew

    There's pretty much a "Hook" for everything that can be made into a shortcut by the nav keys in the shortcuts menu. Here's an example of my files:

    RIGHT_SOFTKEY_HOOK.itm:
    Code:
    RIGHT_SOFTKEY_HOOK.xml                                                                               0100444 0000002 0000002 00000001055 11006351462 0013056 0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    above goes in: tpa/preset/custom/

    RIGHT_SOFTKEY_HOOK.xml
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    above goes in: tpa/preset/system/custmenu/RIGHT_SOFTKEY_HOOK/

    If you need help modifying the code to what you need it to be, ask and I'll see if I can help.

  8. #68
    Join Date
    May 2003
    Location
    Area code 631
    Posts
    294
    Device(s)
    Samsung Intercept
    Carrier(s)
    Virgin Mobile USA
    Feedback Score
    0

    Question

    Quote Originally Posted by NUTSgoWEEE
    Got it!
    Re-loaded all my .xml and .itm files and it worked so I moved onto the menu.ml modding. I noticed there were a lot of "internal" commands so I browsed around for a while. Here's what I came up with: (keep in mind "email" is for the debranded w760i with activesync set up. "messaging" is texting, mms, etc)

    Email Inbox:
    Msg_Email_Inbox

    Write New Email:
    Msg_Email_WriteNew

    Email Menu:
    Messaging_Email

    Messaging Inbox:
    Msg_Inbox

    Write New Message:
    Msg_WriteNew

    There's pretty much a "Hook" for everything that can be made into a shortcut by the nav keys in the shortcuts menu. Here's an example of my files:

    RIGHT_SOFTKEY_HOOK.itm:
    Code:
    RIGHT_SOFTKEY_HOOK.xml                                                                               0100444 0000002 0000002 00000001055 11006351462 0013056 0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    above goes in: tpa/preset/custom/

    RIGHT_SOFTKEY_HOOK.xml
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    above goes in: tpa/preset/system/custmenu/RIGHT_SOFTKEY_HOOK/

    If you need help modifying the code to what you need it to be, ask and I'll see if I can help.
    Could you modify the code for the Left Softkey hook? I've tried it all and I cannot get it to take. Thanks.

  9. #69
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    Here's the LEFT_SOFTKEY_HOOK .itm & .xml files I used (originally from mbkatt)

    LEFT_SOFTKEY_HOOK.itm:
    Code:
    LEFT_SOFTKEY_HOOK.xml                                                                               0100444 0000002 0000002 00000001055 11006351462 0013056 0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    LEFT_SOFTKEY_HOOK.xml:
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Camera" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    If you want it for another function, just change "Msg_Email_Inbox" to another command. I can look up any command or "hook" for you if needed. Make sure you're copying the entire code box because there's information in the .itm file that's not displayed.

    It took me a few tries of uploading the files before it actually took. Good Luck!

  10. #70
    Join Date
    May 2003
    Location
    Area code 631
    Posts
    294
    Device(s)
    Samsung Intercept
    Carrier(s)
    Virgin Mobile USA
    Feedback Score
    0

    Talking

    Quote Originally Posted by NUTSgoWEEE
    Here's the LEFT_SOFTKEY_HOOK .itm & .xml files I used (originally from mbkatt)

    LEFT_SOFTKEY_HOOK.itm:
    Code:
    LEFT_SOFTKEY_HOOK.xml                                                                               0100444 0000002 0000002 00000001055 11006351462 0013056 0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    LEFT_SOFTKEY_HOOK.xml:
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Camera" />
      </item_text>
      <item_help>
        <TEXT lang="xl" str="Inbox" />
        <TEXT lang="cf" str="Inbox" />
        <TEXT lang="pb" str="Inbox" />
        <TEXT default_lang="en" str="Inbox" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Msg_Email_Inbox" />
      </item_action>
    </MenuItem>
    If you want it for another function, just change "Msg_Email_Inbox" to another command. I can look up any command or "hook" for you if needed. Make sure you're copying the entire code box because there's information in the .itm file that's not displayed.

    It took me a few tries of uploading the files before it actually took. Good Luck!
    You're the man! This worked! Here's one thing I did do that wasn't mentioned here:

    After added these files I also deleted cust_menu_data.dat & cust_menu_done_unpacking.dat from the /tpa/preset/system/custmenu folder in the phone. These files are regenerated upon initial bootup after modding.

    Also the one error I noticed in MKBATT's original files was that some of the labels were for different languages, and it wasn't taking. I changed all of the labels to straight English. Everything is working perfectly now! I changed my left softkey to Camera and my right softkey to E-Mail. Thanks to everyone on here for your help!
    Last edited by pmcafee; 02-22-2009 at 05:02 PM.

  11. #71
    Join Date
    Feb 2009
    Posts
    2
    Device(s)
    Sony Ericsson w760a
    Carrier(s)
    at&t,
    Feedback Score
    0
    haha, pmcafee we might have been looking at the same forum. I was looking around at other sites and found one person that said to delete those two files. I also did the same thing with the .itm and .xml files and now everything works. Thanks everyone for posting these. Now to try and get Pandora to work on my w760 (I've been told it won't work, but I'm going to try anyways).

    LEFT_SOFTKEY_HOOK.itm :
    Code:
    LEFT_SOFTKEY_HOOK.xml                                                                               0100444 0000002 0000002 00000001055 11006351462 0013056 0                                                                                                    ustar   root                            root                                                                                                                                                                                                                   ?<?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
        <TEXT default_lang="en" str="Camera" />
      </item_text>
      <item_help>
        <TEXT default_lang="en" str="Camera" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Camera" />
      </item_action>
    </MenuItem>
    LEFT_SOFTKEY_HOOK.xml :
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <MenuItem version="1.0">
      <item_text>
            <TEXT default_lang="en" str="Camera" />
      </item_text>
      <item_help>
            <TEXT default_lang="en" str="Camera" />
      </item_help>
      <item_icon />
      <item_action>
        <ACTION type="Internal" str="Camera" />
      </item_action>
    </MenuItem>

  12. #72
    Join Date
    Jan 2003
    Posts
    205
    Device(s)
    SE C905a
    Feedback Score
    0
    Quote Originally Posted by cooper04
    Now to try and get Pandora to work on my w760 (I've been told it won't work, but I'm going to try anyways).
    man, if you can get pandora to work, that would be awesome!

    I have been using vradio for internet music on my w760, and its pretty good but nothing like Pandora.

  13. #73
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    Pandora's actually something I've been trying to get to work for a while... This isn't really the thread for it thought but if anyone makes any progress, please let me know. I've been emailing pandora support for a while, but they're refusing to send me the program.

    Has anyone had any success trying to download the file? I've tried changing my phone name to w580i but still says my phone isn't supported.

  14. #74
    Join Date
    May 2006
    Posts
    178
    Device(s)
    N8 uh 5
    Carrier(s)
    Cingular
    Feedback Score
    0
    Quote Originally Posted by NUTSgoWEEE
    Pandora's actually something I've been trying to get to work for a while... This isn't really the thread for it thought but if anyone makes any progress, please let me know. I've been emailing pandora support for a while, but they're refusing to send me the program.

    Has anyone had any success trying to download the file? I've tried changing my phone name to w580i but still says my phone isn't supported.
    Easiest thing to do is borrow a friend's W580i and download the jar file - ATT must have sold 85 million of those things, mostly in pink. I was working on the whole pandora thing toward the middle of last year, but got stuck on the ATT RTSP problems, which it looks like can be fixed now. Hmmm...

    Lots of great info in this thread though!

  15. #75
    Join Date
    Jan 2009
    Location
    NY State
    Posts
    26
    Device(s)
    Sony Ericsson j20i Hazel
    Carrier(s)
    AT&T
    Feedback Score
    0
    I don't even know anyone else that has AT&T in my area, let alone a 580i. Anyone with a w580i care to email me or post the .jar file?

Page 5 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast

Bookmarks